Cómo evitar problemas al actualizar WooCommerce

Me he visto en la obligación de escribir esta entrada porque desde hace unos días, en el foro de soporte de WooCommerce y en las comunidades de usuarios, no paro de ver mensajes de gente desesperada preguntando por qué su tienda ha dejado de funcionar correctamente al instalar la última actualización de WooCommerce.

WooCommerce libera una, o a veces incluso dos, actualizaciones menores de media cada mes y una actualización mayor cada seis meses aproximadamente.

Las actualizaciones no se sacan por capricho y de hecho, muchas de ellas corrigen errores (pequeños bugs o ,en el peor de los casos, grandes fallos de seguridad) de las versiones anteriores.

Sabiendo eso, debes tener clara una cosa; cada vez que se libere una nueva actualización, hay que instalarla si o si.

Sin embargo, no es lo mismo instalar una actualización menor, que una actualización mayor. En el caso de esta última, hay que tomar antes una serie de medidas.

Y de eso mismo voy a hablar en esta entrada. De cómo evitar problemas al actualizar WooCommerce o más bien, qué pasos hay que seguir para instalar actualizaciones de forma segura.

Diferencia entre una actualización menor de WooCommerce y una mayor.

Cada actualización de WooCommerce va asociada a un número de versión con un formato de numeración de este estilo; 2.3.4

Empezando por la izquierda, cada vez que se incrementa el primer número, significa que se han introducido grandes cambios o modificaciones del código muy importantes.

El segundo número normalmente indica que se han introducido mejoras de algunas funcionalidades y que se han añadidos otras nuevas.

Y el tercer y último número está relacionado con la corrección de errores.

Te preguntarás; ¿por qué me sueltas este rollo?

Pues porque dependiendo de qué número cambie en la versión, la actualización será más o menos crítica. Es decir, si cambia el último de los 3 números, estaremos ante una actualización menor de WooCommerce, que en el 99% de los casos se puede instalar directamente sin problema. Pero si cambian cualquiera de los 2 primeros números, indicará que se trata de una actualización mayor de WooCommerce y en este caso si hay que tomar una serie de medidas antes de instalarla.

Cada vez que WordPress te notifica una nueva actualización de WooCommerce desde el panel de plugins, éste último te mostrará un mensaje de aviso con recomendaciones a seguir en caso de tratarse de una actualización mayor. Así no tienes que andar revisando el número de versión para saber si la actualización introduce grandes cambios.

Problema al actualizar WooCommerce a la última versión

Pasos para instalar una actualización mayor de WooCommerce de forma segura.

Antes de continuar, quiero dejar claro que no es una obligación seguir los siguientes pasos cada vez que vayas a actualizar WooCommerce. Pero desde luego es la forma más segura de hacerlo y la única que te garantiza que tu tienda siga funcionando sin problema después de actualizar.

Mi recomendación es que apliques los pasos que te voy a explicar a continuación SIEMPRE que vayas a instalar una actualización mayor de WooCommerce.

1. Prueba la nueva versión de WooCommerce en local.

Si aún no tienes una versión de prueba de tu tienda WooCommerce instalada en tu PC, te recomiendo que te la instales ya. Te va a ser muy útil no sólo para probar actualizaciones, sino también para hacer pruebas de diseño o probar nuevos plugins.

Y cuando hablo de una versión de prueba de tu tienda, me refiero a una copia exacta de ella instalada en local (en tu PC o Mac); con los mismos plugins, el mismo tema, los mismos ajustes y algunos productos de prueba (no hace falta que tengas todo el catálogo).

Para poder hacer pruebas en local, necesitas instalar primero un servidor local. No te asustes, es tan sencillo como instalar la aplicación XAMPP en tu PC o Mac y después instalar la última versión de WordPress.

Instala todas las actualizaciones pendientes de plugins y plantilla. Una vez hecho eso, instala la actualización de WooCommerce y después haz varios pedidos de prueba usando todos los métodos de pago que tengas habilitados.

Si no experimentas ningún problema, ¡enhorabuena! La nueva versión de WooCommerce ya ha pasado el primer gran test. Puedes pasar al punto 2 directamente 😉

1.1 Fallo al actualizar en local y qué medidas tomar.

Si por el contrario, te encuentras con algún fallo en el proceso de compra, identifica el problema y toma medidas.

Por ejemplo, la mayoría de problemas relacionados con la apariencia de la tienda (columnas o filas del catálogo superpuestas, botones en la página del carrito que aparecen descolocados o imágenes de productos que no se muestran de forma correcta) se deben a que el tema que estás usando no es compatible con la última versión de WooCommerce.

En ese caso, reporta el error al desarrollador de la plantilla para que la adapte a la nueva versión de WooCommerce cuanto antes. Y aquí es donde radica la principal diferencia entre un tema premium y uno gratuito. Los temas premium se actualizan con más frecuencia y se adaptan mucho más rápido a las nuevas versiones de WooCommerce.

También pueden existir problemas relacionados con incompatibilidades entre los plugins de WooCommerce. En estos casos, los síntomas más comunes son:

  • Siempre se muestran gastos de envío gratuitos aunque tengas que pagar una cierta cantidad por ellos.
  • Cuando vas a la página de pago, se muestra una página en blanco.
  • Al intentar finalizar el pedido la página se queda cargando.
  • No puedes añadir nuevas imágenes de productos desde la página de edición.

Si te encuentras con alguno de estos fallos, entra en la página del log de errores de WooCommerce que encontrarás en «WooCommerce > Estado del Sistema > Logs«.

En esta página se muestra un documento con el listado de errores por orden temporal que se hayan experimentado en tu tienda WooCommerce desde su instalación.

La página de log suele especificar los errores de incompatibilidad relacionados con los plugins de WooCommerce que tengas activos, permitiéndote así detectar el plugin que origina el problema.

En este caso, la medida a tomar será la desactivación del plugin y posterior envío de solicitud de actualización al desarrollador para que corrija los problemas de incompatibilidad. Mientras el desarrollador libera una nueva versión, puedes sustituirlo temporalmente por un plugin compatible que cubra tus necesidades.

Como último recurso, en caso de que no se especifica el origen del error desde la página de log de WooCommerce, no te quedará más remedio que desactivar todos los plugins e ir activando uno a uno hasta dar con el plugin problemático. Obviamente, cada vez que actives uno, tendrás que volver a repetir el proceso que fallaba.

2. Copia de seguridad.

Una vez hechas las pruebas en local, toca hacer una copia de seguridad de la versión en línea de tu tienda WooCommerce.

Aquí puedes optar por 2 métodos:

  • Instalar uno de los muchos plugins disponibles para crear copias de seguridad y generar un backup completo.
  • Hacer la copia manual. Descargando desde un cliente FTP toda la carpeta «wp-content» y descargando una copia completa de la base de datos con phpMyAdmin. (Esta opción sólo la recomiendo si conoces bien la estructura de carpetas de WordPress y te desenvuelves bien con el panel de phpMyAdmin).

Este paso se hace como medida de prevención por si ocurriese algún problema en la actualización de WooCommerce.

3. Actualización de plugins y tema.

Actualiza plugins y tema a las últimas versiones disponibles.

En el caso de los plugins, desactiva y elimina aquellos que no uses.

4. Actualización de WooCommerce.

Este sería el paso crítico y deberás aplicar unas medidas u otras en función de los resultados del paso 1.

4.1 Se han detectado fallos en las pruebas en local.

Si tu tema originaba problemas con la nueva versión de WooCommerce y después de notificar al desarrollador del tema, todavía no ha sacado una versión compatible, mi recomendación es que no actualices WooCommerce hasta disponer de la versión compatible de tu tema. Es normal que se demore unos días.

Ocurre lo mismo con los plugins. Es decir, si alguno de los plugins activos, generaba fallos después de actualizar WooCommerce, no te recomiendo actualizar este último hasta que no haya disponible una versión compatible del plugin.

Si después de un tiempo de espera (máximo 2 semanas), siguen sin estar disponibles las versiones compatibles del tema y los plugins, deberás plantearte sustituirlos por otros totalmente compatibles y así poder actualizar WooCommerce de forma segura.

4.2 No se detectaron fallos en las pruebas en local.

En ese caso, ¡enhorabuena!

Puedes actualizar WooCommerce sin problema y empezar a disfrutar de todas sus mejoras y nuevas funcionalidades.

Ahh!! Se me olvidaba una cosa.

Te agradecería muchísimo que me ayudases a difundir este post y ayudar así a otras personas. Sólo tienes que compartir usando cualquiera de los botones que tienes justo debajo y si es el de Google+, mejor aún. Aunque cualquiera me vale 🙂

60 comentarios en “Cómo evitar problemas al actualizar WooCommerce”

  1. Hola buenas tardes, hace relativamente poco que instale woocommerce i la verdad que me pareció en primer momento un gran salto adelante, pero voy muy perdido. Hace poco detecte que mis productos no se indexaban como esperaba i observe que dos fallos de plantilla por obsoletas :
    La versió – de schema-lite/woocommerce/archive-product.php és obsoleta. La versió del nucli és la 3.4.0,
    La versió – de schema-lite/woocommerce/single-product.php és obsoleta. La versió del nucli és la 1.6.4
    Me indica que debo actualizarlas pero francamente se me hace una montaña.
    He intentado instalar otros temas por probar si incluían las plantillas ya actualizadas, pero o no he acertado con los temas que he probado o definitivamente no es la solución. He intentado instalar algun plugin, Rich Snippets, para ver si podia cubrir dichas limitaciones, pero creo que crean mas incompatibilidades que soluciones y ya voy casi a la desesperada, me he llegado a plantear desinstalar woocommerce i volverlo a instalar con una version actualizada, pero francamente me parece una locura…
    Me podrías orientar minimamente para dejar de dar palos de diego? Gracias de antemano.

  2. Hola, muy buen artículo.
    Tengo una duda, es posible crea algo parecido a un Child Theme pero para los plugin.
    Es decir que podamos hacer cambios a un plugin y que estos cambios no se pierdan cuando actualicemos el plugin.

    1. Hola Enderson!

      No, no se puede 🙁

      Lo más parecido a eso sería un add-on, es decir, un plugin que se «conecta» al plugin «padre» y modifica su comportamiento. Pero para poder hacer eso, necesitas que el plugin padre cuente con funciones hook (es decir, actions y filters) a los que poder enganchar el add-on para modificar el comportamiento del plugin original sin tocar su código.

      Espero haberte aclarado la duda.

      Saludos!

  3. Hola! Estoy migrando de servidor desde dreamhost a hostinger por capacidades de recursos, instalamos unn copia del sitio de modo prueba en hostinger y resulta que no puedo utilizar ninguno de los importadores masivos que utilizo en el actual.
    Detallo plugin utilizados y errores que genera:
    1- Product CSV Import – Export (BASIC) – WooCommerce está actualizando los datos de los productos en segundo plano
    Puede que la visualización del producto, la ordenación y los informes no sean precisos hasta que el proceso termine. Este proceso puede tardar unos minutos y este aviso desaparecerá cuando termine. Ver progreso → (ejecuto todos los procesos pendientes y no actualiza, ni siquiera llega a ejecutar todos)
    2- WP All Import: Hay un problema con su archivo de importación. Verifique que el archivo que utiliza sea válido.
    3- Importador masivo de WP – El archivo no existe, inténtalo de nuevo, por favor.

    Todos son de importación de productos. En mi sitio actual, puedo actualizar sin inconvenientes con todos, lo cual creo que tiene que ver con alguna configuración del Hosting, me contacte con ellos y me piden que me comunique con wordpress. De verdad no se como resolverlo, ya probé mil opciones y no encuentro solución.
    Por favor si me pueden ayudar.

    Gracias!

  4. Hola, me pueden ayudar con este error? Me aparecía el siguiente error
    [02-Dec-2020 04:26:16 UTC] PHP Warning: include(): Failed opening '/home/agenci71/public_html/centrotec.cl/wp-content/plugins/woocommerce/templates/single-product/price.php' for inclusion (include_path='.:/opt/alt/php72/usr/share/pear') in /home/agenci71/public_html/centrotec.cl/wp-content/plugins/woocommerce/includes/wc-core-functions.php on line 345

    Y tras agregar '.:/opt/alt/php72/usr/share/pear' en la línea 345, me aparece el siguiente error:
    [02-Dec-2020 04:26:16 UTC] PHP Warning: include(/home/agenci71/public_html/centrotec.cl/wp-content/plugins/woocommerce/templates/single-product/price.php): failed to open stream: No such file or directory in /home/agenci71/public_html/centrotec.cl/wp-content/plugins/woocommerce/includes/wc-core-functions.php on line 345

    Agradecería la ayuda. Tengo Cpanel.

  5. Hola,
    Ayer intenté hacer una actualización de Woocommerce y la página se me quedó por completo en blanco y me dabau un mensaje donde decía que había habido un error crítico y no se podía acceder a la página. Tuve que restaurar a la última versión desde Web empresa. Ya no me atrevo a volver a actualizar, ya que no sé a que se debe este error. Por favor, ¿me puedes ayudar? ¿Sabes a qué puede ser debido este problema? ¿Hay que hacer algún cambio en algún otro parámetro?
    Gracias.

  6. Hola,
    Hace tiempo que te sigo y me gusta mucho tu trabajo. Me ha surgido un problema al actualizar la base de datos de Woocommerce, esta no se me actualiza… qué podría hacer?
    Muchas gracias

    1. Hola Ricardo!

      Lo más rápido es preguntar al servicio técnico de tu hosting y ellos pueden ver desde el log de errores dónde está el problema y decirte cómo solucionarlo.

      Saludos!

    1. Hola Pedro!

      Eso tiene toda la pinta deberse a una incompatibilidad entre plugins o con el tema.

      Entra por FTP a tu servidor, desactiva todos los plugins y vuelve a probar. Si no se soluciona, prueba también desactivando el tema.

      Después de eso ya si deberías poder acceder al escritorio de WP y borrar el plugin (o el tema) que esté causando el problema.

      Saludos!

  7. Caballero, me es un gusto saludarlo.

    Me gustaría acercarle una inquietud que me tiene muy preocupado: Dado el caso, si por error e ignorancia, actualizamos el plugin WooCommerce sin haber tenido en cuenta todo lo que usted menciona aquí, quiere decir que hemos perdido toda la información que se relacionaba con WooCommerce?
    Le agradezco inmensamente si me puede brindar cualquier información, ya que, he actualizado el plugin por hábito, ahora no puedo acceder a nada que se relaciona con WooCommerce, adicional a eso, no me es posible instalarlo nuevamente, dice que esa carpeta ya existe.

    Att: Andrés Leandro Ospina

    1. Hola Leandro!

      Si a la hora de actualizar, no has seguido el orden que explico en el post, es probable que se haya generado un error de incompatibilidad con otros plugins y por eso ahora tienes todos esos problemas.

      La solución sería desactivar el resto de plugins y activar uno de los temas por defecto de WordPress. Si al hacer esto, ya vuelves a tener acceso al panel de WC, entonces se confirma que el problema es de incompatibilidad con alguno de los plugins o con el tema.

      En ese caso, tendrás que ir activando uno a uno y repitiendo el proceso hasta dar con el plugin (o tema) que genera la incompatibilidad. Y cuando lo encuentres, eliminarlo o reemplazarlo por uno compatible.

      Espero que te sirva.

      Saludos!

  8. Hola Antonio,

    Es la primera vez que estoy haciendo una prueba con un Host Local (MAMP), y cuando quiero instalar el Plugin de WooCommerce en WordPress, me aparece: ¡Fallo al actualizar! Sinceramente no sé cómo avanzar ¿podrás ayudarme?
    Gracias!

    1. Hola Mónica!

      Para ver dónde está el problema te recomiendo activar el log de depuración de WordPress (aquí te explican cómo hacerlo). Cuando lo tengas activado, vuelve a reproducir el fallo y toda la información sobre este quedará registrada en el archivo de log.

      Con esa info ya podrás saber qué origina el problema. Aunque yo me atrevería a decir que tiene pinta de ser por culpa de los permisos de los directorios de la instalación de WordPress.

      Espero haberte ayudado.

      Saludos!

  9. Hola Antonio,
    Al actualizar el WooCommerce mi pagina dejo de funcionar, 500 Internal Server Error, desde cPanel he conseguido desactivar el woo, borrando todos los productos de la tienda de paso, he actualizado el tema y el propio wordpress pero cada vez que intento volver a activar el woo, me vuelve a salir el mismo error. Se te ocurre alguna solucion? Muchas gracias.

    1. Hola Aksana!

      Lo único que se me ocurre es que restaures la última copia de seguridad anterior a la actualización de WooCommerce. Si no creaste copias, probablemente tu hosting tenga alguna.

      Espero que lo puedas solucionar pronto.

      Saludos

  10. Hola!, Antonio
    tengo un problema con la ultima actualizacion de woocommerce 4.6, no se muestran las imagenes de mis productos, solo se muestra el precio y el nombre como puedo solucionarlo?

  11. hola antonio!!!instale una nva versión de wp e commence, agregando el archivo desde dashboard de worpress!!! no realice una copia de seguridad y me surgió tal problema: Error grave : no se puede redeclarar la clase MercadoPagoException en /home/content/01/11087101/html/8bit/rrintec.com/wp-content/plugins/wp-e-commerce/wpsc-merchants/mercadopago-lib/mercadopago.php on line 881!!!!que puedo hacer para solventarlo!!!pues ya cargue el archivo desde ftp en la dirección que me indica pero nada cambia!!!

  12. Hola, como estas, fijate que en mi caso al actualizar a la última versión de Woocommerce me lanza ciertos errores en el estatus del sistema, me indica lo siguiente:

    La version 2.0.0 de ***mitema***/woocommerce/loop/rating.php está obsoleta. La versión del núcleo es la 3.0.0,
    La version 2.0.0 de ***mitema***/woocommerce/loop/result-count.php está obsoleta. La versión del núcleo es la 3.0.0,
    La version 1.6.4 de ***mitema***/woocommerce/single-product/meta.php está obsoleta. La versión del núcleo es la 3.0.0,
    La version 2.4.9 de ***mitema***/woocommerce/single-product/price.php está obsoleta. La versión del núcleo es la 3.0.0,
    La version 2.1.3 de ***mitema***/woocommerce/single-product/product-attributes.php está obsoleta. La versión del núcleo es la 3.0.0,

    Entiendo que debo de actualizar la plantilla, pero esta actualizada la ultima versión de woo, la ultima versión de wordpress y no sé donde entrarle.

    1. Hola JH,

      Este tipo de situaciones se suele dar cuando estás trabajando con un tema hijo que incluye sus propias plantillas de páginas de WooCommerce. El tema hijo sobre-escribe las plantillas del tema padre y de esta forma aunque el tema padre esté actualizado, las plantillas que WooCommerce detecta son las plantillas sin actualizar del tema hijo.

      Si es tu caso, la solución pasa por copiar la carpeta /woocommerce/ del tema padre y reemplazarla por la que tienes en el tema hijo.

      Saludos!

  13. Hola Antonio mi problema es que algunas traducciones de mi tienda no consigo realizarlas, he probado a modificar el archivo woocommerce-es_ES.po con Poedit pero ahí está todo traducido. Tengo la Versión 2.7.0-beta-1, la verdad es que no se que hacer. Gracias

  14. Hola:

    He estado trabajando con una plan gratuito de hostinger y su vez he creado una tienda on line con woocomerce. Casi finalizada la tienda he dado a actualizar a woocomerce y he perdido toda la información que tenia. No tenia hecha ninguna copia de seguridad. Estoy perdido y desesperado.

  15. Hola tengo un problema utilizo la plantilla Virtue en Woocommerce en WordPress 4.7 y tengo un producto con atributo y variaciones y al actualizar ese producto aparecen las variaciones en la web pero no cambia de una a otra aunque les pinches siempre aparece la misma variacion. Alguien puede ayudarme? Muchas gracias.

  16. Hola,
    He intentado desactivar los pluggins de woocommerce en mi escritorio de WordPress y ahora no puedo acceder a mi wp admin ni realizar ningún tipo de acción. Me aparece el siguiente error :
    Fatal error: Call to undefined function WC() in /home/u146835218/public_html/wp-content/plugins/woocommerce-gateway-stripe/woocommerce-gateway-stripe.php on line 227
    Por favor necesito ayuda, estoy trabajando en un proyecto que debería publicarse esta semana y no sé qué hacer. Gracias de antemano.

    1. Hola Miguel,

      Espero que las modificaciones no las hayas hecho en los archivos del plugin, porque si es así, no vas a poder actualizar sin perderlas. Aparte de que es una práctica muy arriesgada que puede provocar grandes fallos en la tienda.

      Si por el contrario las modificaciones las has incluido en el archivo functions.php del tema, puedes actualizar WooCommerce sin miedo. Pero deberías usar un tema hijo para no perderlas.

      Un saludo!

      1. Hola. Gracias por responder.
        Las modificaciones si han sido hechas dentro del plugin..
        Me confirmas lo que leí por ahí, no se puede.
        En cambio para le theme si tengo tema hijo.

        La única solución por tanto es guardar los archivos modificados, actualizar y vovler a implementarlos…

        Saludos.

  17. Hola Antonio!
    Tengo mi tienda online funcionando y he decidido cambiar de plantilla. Hice una copia en local de mi tienda, instalé la plantilla nueva, hice los cambios pertinentes, pero no se como subirla de nuevo online sin que me sobreescriba los datos de ventas,stock, etc que he tenido en el tiempo que he estado construyendo la nueva plantilla. ¿Alguna sugerencia?

  18. Hola acabo de instalar WooCommerce por primera vez y todo funciona bien, excepto la página de mi blog o las URL que llevan a archivos del mes o archivos de categoría… Solamente se despliega una ventana en blanco. Desactivé woocommerce y todo funciona bien.
    La única extensión que tengo es la de PayPal Express y en el estado del sistema de WooCommerce no me indica ningún error.

    Saludos y gracias por tu apoyo

  19. Hola, he actualizado la versión de woocomerce, cuando le doy a la pagina del carrito me aparece en blanco, como puedo volver a la versión anterior de woocomerce? se te ocurre alguna otra solución que no sea bajar la versión del plugin?

    1. Hola Amparo,

      Puede que hayas eliminado la página de carro sin darte cuenta.

      Para crearla de nuevo entra en «WooCommerce > Estado del sistema > Herramientas» y haz clic en «Instalar páginas».

      Si lo anterior no te resuelve el problema, también puede deberse a un fallo con los enlaces permanentes. En ese caso, entra en «Ajustes > Enlaces permanentes» y guarda los cambios (no hace falta que toques nada más).

      Espero que te sirva.

      Saludos!

  20. Hola!!!

    Como siempre un artículo de 10

    HE seguido todos los pasos. Y después de actualizar woocommerce, me aparece este mensaje:

    WooCommerce requiere actualización de datos- sólo tenemos que actualizar su instalación a la última versión

    Si le doy me dice que haga un respaldo de la BBDD

    Sabes esto para que sirve? Es obligatorio?

    Como no lo mencionas en el post me ha parecido raro

    Saludos!!!

    1. Hola Alejandro,

      No te preocupes.

      Ese mensaje suele mostrarse con actualizaciones mayores que incluyen alguna modificación en la base de datos. A mi también me ha aparecido algunas veces.

      Simplemente haz antes una copia de la base de datos (es para ser precabido) y después actualiza.

      Espero que te funcione todo.

      ¡Saludos!

  21. La traducción de woocommerce es… como decirlo, nada profesional y contiene errores gramaticales.

    En el backend no tienen mayor importancia pero que en frontend, no son apropiadas para dar una buena imagen en una tienda.

    Hay alguna forma de actualizar los archivos de traducción (.po / .mo) sin tener que empezar de cero con cada nueva versión. Y lo mismo ocurre con las personalizaciones de las plantillas de los eMails, se pierden con cada nueva versión.

    Gracias, salud2.

    1. Hola Gosser,

      Te doy toda la razón en lo de las traducciones. Es una cosa que hay que mejorar de WooCommerce.

      Las traducciones del backend dependen de WooCommerce, pero se hacen de forma colaborativa (es decir, cualquiera puede aportar las suyas propias), todo el que quiera puede enviar sus traducciones y aunque el equipo de WooCommerce las revisa antes de aceptarlas, al no tener revisores en español, aceptan muchas traducciones mal hechas.

      Aquí dejo el enlace para colaborar en las traducciones de WooCommerce –> https://www.transifex.com/woothemes/woocommerce/

      En el caso del frontend, dependen del desarrollador del tema, no de WooCommerce. En ese caso, se puede contactar con el soporte técnico del tema y decirles que corrijan las traducciones mal hechas.

      Un saludo!

  22. Hola,
    Una pregunta tengo una tienda en construccion y Woocommerce me esta actualizando automaticamente la version y me dana la plantilla que uso, como paro las actualizaciones automaticas de woocommerce.

    Gracia por su tiempo y ayuda

    1. Hola Elsa,

      Las actualizaciones automáticas no dependen de WooCommerce sino de la configuración de WordPress.

      Te recomiendo que contactes con tu empresa de hosting para que te la desactiven.

      Un saludo!

  23. Hola. Tengo una duda respecto a woocommerce. Hay tipos de monedas el no trae en la librería por defecto al instalarlo; sin embargo, he ingresado por mis archivos y modificado la carpeta de woocommerce en la sección del tipo de moneda y agregué satisfactoriamente a través de código. El problema empieza al momento de instalar una nueva actualización de woocommerce, el sistema queda en su modelo por defecto y desaparece la moneda. ¿qué debo hacer para que los ajustes que yo haga no se modifiquen con cada actualización?

    1. Hola Luis,

      NUNCA debes modificar el código de los archivos originales del plugin, precisamente porque pierdes los cambios al actualizar. Además de arriesgarte a «romper» el código y dejar tu tienda online sin funcionar.

      Para añadir nuevos tipos de moneda, puedes usar este plugin WooCommerce Custom Currencies.

      Saludos!

  24. Buenas tardes!!

    Ante todo te felicito por el post, aunque para mi ya es un poco tarde. He actualizado el plugin de woocormmece y para mi fustración total, ahora me ha desaparecido, y no tengo acceso a ninguna parte de la tienda.
    He probado a subir de nuevo el plugin, pero el sistema me dice que hay un fallo al instalarlo porque ya existe un archivo

    «Descargar el archivo de instalación de

    https://downloads.wordpress.org/plugin/woocommerce.2.3.9.zip…

    Descomprimir…
    Instalando el plugin…
    La carpeta ya existe. /Homepages/ 15/d524653213/htdocs/app524653254/wp-content/plugins/woocommerce/
    Fallo en la instalación del plugin.»

    Total que ahora no tengo acceso a ninguna parte de la tienda. Si intento acceder a la barra de administracion me dice «Tipo de entrada no válido»

    Existe alguna manera de arreglarlo teniendo en cuenta de que no soy ninguna experta en programacion?

    Muchisimas gracias

    1. Hola M.Carmen,

      Tu problema puede deberse a varios factores, pero yo empezaría por desactivar tu plantilla y activar cualquier tema por defecto de WordPress por ejemplo, twentyfifteen.

      Si después de hacer eso, se soluciona el problema, ya sabes que el fallo está en tu plantilla.

      Si eso no funciona, entonces empieza a desactivar plugins porque casi seguro se trata de alguna incompatibilidad.

      Espero que lo soluciones pronto.

      Un saludo!

      1. hola antonio ya hice todo lo que mencionas y nada me resulta mira como queda no funciona woocommerce ya llevava mi academia un año funcionando sisn porblemas se iscribian pagaban con paypal y solitos iban alos videos y regresaban cuantas veces quisiera que hago? ayuda

        http://cursos.elemprendedorinteligente.com/mis-cursos/

  25. Buenas tardes:

    Antes de nada quiero agradecer tu trabajo en este blog, pues es de gran ayuda a quienes tratamos de introducirnos en el mundo de Woocommerce. Mi problema es que cada vez que se actualiza Woocommerce tengo que volver a añadir los archivos de mi TPV virtual (redsys) porque, para que funcione, debo cambiar unos códigos para que funcione en un entorno https (con certificado SSL). Es un poco rollo porque Woocommerce se actualiza de manera constante, y siempre ando con lo mismo. ¿Sabes si hay alguna manera de evitar esto?

    Un saludo, y muchas gracias.

    1. Hola Álvaro,

      El problema que comentas no es de WooCommerce sino del plugin que estás usando para tu TPV virtual. No es normal que tengas que modificar códigos, de hecho, no es NADA recomendable tocar el código fuente ni añadir ficheros a la carpeta de WooCommerce.

      Te recomiendo que compres un plugin premium para tu pasarela Redsys. De hecho, estoy terminando de desarrollar mi propio plugin premium para TPVs con Redsys. Cuando lo haya testado lo pondré a la venta en el blog y le daré soporte yo mismo.

      Saludos!

      1. Muchísimas gracias, de verdad. En cuanto lo tengas a ver si me entero y lo compro. La verdad es que Redsys tiene complicaciones con el SSL, porque encima no es compatible con los SSL de servidores compartidos (el hosting más habitual). Así que no sé si dejaré de usar este tipo de servicio de pago, pero la verdad es que no están muy adaptados a los nuevos tiempos. Gracias de nuevo, un saludo. Enhorabuena por tu trabajo.

  26. Hola, estoy haciendo un sitio con WooCommerce y se me ha presentado el siguiente problema:

    El hecho es que los filtros por atributos me dejaron de funcionar, reinstale wordpress y desactive y active WooCommerce, y nada, estoy utlizando la ultima version de wordpress y woo.

    La única solución que encontre fue volver a crear una instalción de wordpress y copiar los plugins y temas again y así todo volvió a funcionar pero el hecho es que dejaron de funcionar de nuevo, y me preocupa que cuando tenga el proecto online le pase.

    Por favor si te ha ocurrido el problema y has encontrado una solución mas práctica.

    Saludos y gracias de antemano.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Responsable: Antonio Cantero, siendo la Finalidad; envío de mis publicaciones así como correos comerciales. La Legitimación; es gracias a tu consentimiento. Destinatarios: tus datos se encuentran alojados en mi plataforma de email marketing Active Campaign ubicada en EEUU y acogida al Privacy Shield. Podrás ejercer Tus Derechos de Acceso, Rectificación, Limitación o Suprimir tus datos en contacto@woodemia.com

Ir arriba